User Tools

Site Tools


fr:telechargement_du_logiciel_demexp

Téléchargement et installation de demexp

La version stable la plus récente est la 0.8.3. C'est la version qui est proposée sur cette page (sauf mention spéciale), pour différentes systèmes d'exploitation. Pour obtenir une version plus ancienne, vous pouvez vous rendre sur la page de développement.

GNU/Linux

Debian GNU/Linux

Pour la distribution Debian GNU/Linux, il y a plusieurs paquets disponibles :

  • les paquets pour utiliser demexp :
    • le paquet demexp-server contient le serveur de vote ainsi que sa documentation (le PDF engendré par LaTeX/noWeb)
    • le paquet demexp-client-gtk2 contient le client qui permet de se connecter à un serveur demexp pour soumettre des votes, voter, etc. et contient également sa documentation
  • les paquets nécessaires si vous souhaitez compiler demexp :
    • librpc-ocaml-dev, disponible dans Debian, la dernière version se trouvant toujours sur le miroir de Thomas
    • libgz-ocaml-dev et libgz-ocaml, dont la dernière version se trouve sur le miroir de Thomas
    • cduce, disponible dans Debian, la dernière version se trouvant toujours sur le miroir de Thomas

Pour y avoir accès, il faut ajouter à votre fichier /etc/apt/sources.list une des lignes suivantes, en fonction de votre distribution :

Ensuite il faut suivre la procédure d’installation classique sous Debian (faire apt-get update, puis apt-get install demexp-client-gtk2 par exemple).

Si à l'installation, vous avez un problème de version des paquets, c'est très certainement parce que vous avez mis la mauvaise ligne dans votre ”/etc/apt/sources.list”. Rappelons encore une fois qu'au jour d'aujourd'hui Sarge=OldStable, Etch=stable et Sid=unstable.

Note: le mainteneur des paquets Debian ne possède pas d'installation des distributions Debian Sarge et Debian Etch, il ne peut donc pas les tester. N'hésitez pas à remonter les problèmes via la liste de diffusion de demexp.

Merci à Thomas Petazzoni pour la construction du paquet Debian (http://thomas.enix.org/Blog-20060327224232-Technologie)

Ubuntu

Les paquets disponibles pour les distributions Ubuntu Breezy et Dapper sont les mêmes que ceux disponibles pour la distribution Debian, sauf les paquets de la version 0.4 de demexp qui ne sont pas disponibles.

Pour y avoir accès, il faut ajouter à votre fichier /etc/apt/sources.list

Puis, suivre la procédure d'installation classique sous Ubuntu (faire sudo apt-get update, puis sudo apt-get install demexp-client-gtk2 par exemple).

Les dépôts de données ne sont pas (encore ?) signé numériquement avec pgp (ou gpg). Vous pouvez donc obtenir une erreur lorsque vous tapez sudo apt-get update. Ignorer simplement l'avertissement et continuez l'installation.

Note: le mainteneur des paquets Ubuntu ne possède pas d'installation des distributions Ubuntu, il ne peut donc pas les tester. N'hésitez pas à remonter les problèmes via la liste de diffusion de demexp.

Merci à Thomas Petazzoni pour la construction des paquets Ubuntu (http://thomas.enix.org/Blog-20060327224232-Technologie).

Windows

Installateur pour windows de la version stable 0.8.3.

Un installateur GTK est intégré, le fichier manquant est installé avec le reste de demexp. En revanche, tant le logiciel que l'installateur sont en phase de stabilisation. Aucun problème majeur n'est connu mais plusieurs soucis d'installation ont été rapportés. Tout rapport sur le fonctionnement est le bienvenu sur les listes de diffusion.

Merci à Christophe.

Source

Des archives de la dernière versions des sources, des branches stables et en développement, sont disponibles à l'adresse : http://www.linux-france.org/~dmentre/demexp/latest-src/

Le dépôt du code source est géré à l'aide du logiciel Mercurial. Voir cette page pour plus d'informations.

Les versions 0.x, avec x pair, sont des versions stables (ou supposées l'être ;). Les versions 0.y, avec y impair, sont des versions de développement.

Vieux paquets, pour d'autres systèmes

Les paquets suivants ne sont plus à jour. Mais si vous êtes motivés, nous prendrons avec plaisir toutes les contributions, pour tous les systèmes.

MacOS X

François-Xavier Ponscarme a réalisé une version de demexp pour MacOS X : http://www.linux-france.org/~dmentre/demexp/binaries/macosx-demexp-gtk2-client-0.6.gz

Malheureusement, il semble que cette version ne marche pas très bien, des bibliothèques sont manquantes1). Si quelqu'un veut faire une version avec un programme d'installation et une documentation sur sa compilation, nous sommes preneur. ;-)

En attendant, vous pouvez compiler vous-même à partir des sources. Consultez à ce sujet les notes de compilation pour mac.

Mandriva

Christophe Guilloux a travaillé sur des paquets Mandriva. Ils sont déjà assez anciens. Le packetage ne semble plus être inclus dans les sources urpmi de Mandriva 2006.

Thomas Petazzoni a commencé à reprendre le travail de Christophe Guilloux et à l'actualiser pour la nouvelle version de Mandriva. Ce travail est disponible sur un dépôt Subversion, accessible à l'adresse https://ssl.bulix.org/svn/thomas/mandriva/. Cependant, le travail est loin d'être terminé : contrairement à Debian où beaucoup de dépendances de demexp sont déjà empaquetées, Mandriva n'empaquete presque rien au niveau Objective Caml. Pour l'instant, le travail est à l'arrêt, car l'orientation du projet demexp vers le développement d'un client Web a réduit la motivation pour la création de paquets pour le client graphique lourd.

Gentoo Linux

Attention: le paquet pour Gentoo n'est pas la version la plus récente, il s'agit de la 0.5.4.

Le paquet est disponible ici. Le README indique comment utiliser l'overlay Gentoo.

Merci à Thomas De Grenier De Latour pour la construction du paquet Gentoo.

fr/telechargement_du_logiciel_demexp.txt · Last modified: 2015/05/06 13:44 by 217.128.134.71